DL is deprecated, please use Fiddle

問題

rails -v したときや irb 実行時に DL is deprecated, please use Fiddle と出力されて邪魔。

事象

C:\Users\daisuke>rails -v
DL is deprecated, please use Fiddle
Rails 4.2.0

トラブルシュート

readline

原因

Ruby Installer for Windowsに添付されているreadlineライブラリがDLという古いライブラリを使っているため

解決策

仕方ないので無視。。

参考

[pukiwiki]
-『たのしいRuby 第4版』正誤表 – http://www.notwork.org/tanoshiiruby4/errata.html
– teratail — [[Rubyのインストール時に表示されたエラーメッセージ「DL is deprecated, please use Fiddle」について:https://teratail.com/questions/1411]]
[/pukiwiki]

スポンサーリンク

シェアする

フォローする

スポンサーリンク