Windows 2008 R2 で fluentd を利用する 1 – fluentd のインストール

Contents

概要

Windows 2008 R2 に fluentd をインストールし、fluentd クライアントとして利用できるようにします。

手順

Ruby 2.2 系のインストール

・Ruby Installer をダウンロードして v2.2 系の最新版をインストール
現時点では v2.2.5 が最新でした。

fluentd-on-windows2008r2_1

環境変数 PATH を設定するにチェックを入れます

・Devkit のインストール
現時点では v4.7.2-20130224-1432 が最新の様です。

DevKit の初期化

実行コマンド

ruby dk.rb init
ruby dk.rb install

init を実行したら、rubydevkit フォルダ配下の config.yml に Ruby のインストールパスを追加します。画像は Ruby 2.2.5-p319 x64 デフォルトインストールパス利用時の場合です。

fluentd-on-windows2008r2_2

config.yml に Ruby のインストールパスを追加

>cd c:\rubydevkit
c:\rubydevkit>ruby dk.rb init

Initialization complete! Please review and modify the auto-generated
'config.yml' file to ensure it contains the root directories to all
of the installed Rubies you want enhanced by the DevKit.

c:\rubydevkit>ruby dk.rb install
[INFO] Updating convenience notice gem override for 'C:/Ruby22-x64'
[INFO] Installing 'C:/Ruby22-x64/lib/ruby/site_ruby/devkit.rb'

Git for Windwos のインストール

Git for Windows 入手先 からダウンロードの上、すべてデフォルトオプションでインストール。現時点での最新は v2.10.1 の様です。

Git で fluentd のリポジトリをクローンする

一時フォルダ内にクローンしておきます。

実行コマンド

cd %temp%

git clone https://github.com/fluent/fluentd.git
>cd %temp%
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1>git clone https://github.com/fluent/fluentd.git
Cloning into 'fluentd'...
remote: Counting objects: 20241, done.
remote: Compressing objects: 100% (135/135), done.
remote: Total 20241 (delta 73), reused 0 (delta 0), pack-reused 20093R
Receiving objects: 100% (20241/20241), 13.82 MiB | 135.00 KiB/s, done.

Resolving deltas: 100% (13046/13046), done.

bundler と bundle に必要な gem のインストール

クローンした fluentd リポジトリフォルダ内に移動して gem パッケージにするためには、bundler が必要です。また、gem をインストールするために rubygems.org に接続しますが、HTTPS の証明書エラーがでるため暫定的に HTTP 経由でダウンロードできるようにして作業を進めます。

実行コマンド

cd fluentd
gem source -a http://rubygems.org/
gem install bundler
gem install rake -v ‘11.3.0’
gem install cool.io -v ‘1.4.5’
gem install docile -v ‘1.1.5’
gem install ffi -v ‘1.9.14’
gem install flexmock -v ‘2.3.1’
gem install http_parser.rb -v ‘0.6.0’
gem install msgpack -v ‘1.0.2’
gem install sigdump -v ‘0.2.4’
gem install win32-api -v ‘1.6.0’
gem install strptime -v ‘0.1.8’
gem install thread_safe -v ‘0.3.5’
gem install yajl-ruby -v ‘1.2.1’
gem install json -v ‘2.0.2’
gem install oj -v ‘2.17.5’
gem install parallel -v ‘1.9.0’
gem install power_assert -v ‘0.3.1’
gem install rr -v ‘1.2.0’
gem install simplecov-html -v ‘0.10.0’
gem install timecop -v ‘0.8.1’
gem install ffi-win32-extensions -v ‘1.0.3’
gem install win32-ipc -v ‘0.6.6’
gem install windows-api -v ‘0.4.4’
gem install tzinfo -v ‘1.2.2’
gem install parallel_tests -v ‘0.15.4’
gem install test-unit -v ‘3.2.1’
gem install simplecov -v ‘0.12.0’
gem install win32-service -v ‘0.8.9’
gem install win32-event -v ‘0.6.3’
gem install windows-pr -v ‘1.2.5’
gem install tzinfo-data -v ‘1.2016.8’
gem install test-unit-rr -v ‘1.0.5’
gem install serverengine -v ‘2.0.1’

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1>cd fluentd
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem source -a http://rubygems
.org/
https://rubygems.org is recommended for security over http://rubygems.org/

Do you want to add this insecure source? [yn]  y
http://rubygems.org/ added to sources

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install bundler
Fetching: bundler-1.13.6.gem (100%)
Successfully installed bundler-1.13.6
Parsing documentation for bundler-1.13.6
Installing ri documentation for bundler-1.13.6
Done installing documentation for bundler after 16 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed

上記のように、bundler 自体のインストールはすぐ終わるのですが、fluentd を bundle する際に必要となる gem が揃っている必要あります。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install rake -v '11.3.0'
Fetching: rake-11.3.0.gem (100%)
rake's executable "rake" conflicts with C:/Ruby22-x64/bin/rake
Overwrite the executable? [yN]  y
Successfully installed rake-11.3.0
Parsing documentation for rake-11.3.0
Installing ri documentation for rake-11.3.0
Done installing documentation for rake after 2 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install cool.io -v '1.4.5'
Fetching: cool.io-1.4.5-x64-mingw32.gem (100%)
Successfully installed cool.io-1.4.5-x64-mingw32
Parsing documentation for cool.io-1.4.5-x64-mingw32
Installing ri documentation for cool.io-1.4.5-x64-mingw32
Done installing documentation for cool.io after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install docile -v '1.1.5'

Fetching: docile-1.1.5.gem (100%)
Successfully installed docile-1.1.5
Parsing documentation for docile-1.1.5
Installing ri documentation for docile-1.1.5
Done installing documentation for docile after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install ffi -v '1.9.14'
Fetching: ffi-1.9.14-x64-mingw32.gem (100%)
Successfully installed ffi-1.9.14-x64-mingw32
Parsing documentation for ffi-1.9.14-x64-mingw32
Installing ri documentation for ffi-1.9.14-x64-mingw32
Done installing documentation for ffi after 4 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install flexmock -v '2.3.
1'
Fetching: flexmock-2.3.1.gem (100%)
Successfully installed flexmock-2.3.1
Parsing documentation for flexmock-2.3.1
Installing ri documentation for flexmock-2.3.1
Done installing documentation for flexmock after 2 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install http_parser.rb -v
 '0.6.0'
Fetching: http_parser.rb-0.6.0.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
Successfully installed http_parser.rb-0.6.0
Parsing documentation for http_parser.rb-0.6.0
Installing ri documentation for http_parser.rb-0.6.0
Done installing documentation for http_parser.rb after 3 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install msgpack -v '1.0.2
'
Fetching: msgpack-1.0.2-x64-mingw32.gem (100%)
Successfully installed msgpack-1.0.2-x64-mingw32
Parsing documentation for msgpack-1.0.2-x64-mingw32
Installing ri documentation for msgpack-1.0.2-x64-mingw32
Done installing documentation for msgpack after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install sigdump -v '0.2.4
'
Fetching: sigdump-0.2.4.gem (100%)
Successfully installed sigdump-0.2.4
Parsing documentation for sigdump-0.2.4
Installing ri documentation for sigdump-0.2.4
Done installing documentation for sigdump after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install win32-api -v '1.6
.0'
Fetching: win32-api-1.6.0-universal-mingw32.gem (100%)
Successfully installed win32-api-1.6.0-universal-mingw32
Parsing documentation for win32-api-1.6.0-universal-mingw32
Installing ri documentation for win32-api-1.6.0-universal-mingw32
Done installing documentation for win32-api after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install strptime -v '0.1.
8'
Fetching: strptime-0.1.8-x64-mingw32.gem (100%)
Successfully installed strptime-0.1.8-x64-mingw32
Parsing documentation for strptime-0.1.8-x64-mingw32
Installing ri documentation for strptime-0.1.8-x64-mingw32
Done installing documentation for strptime after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install thread_safe -v '0
.3.5'
Fetching: thread_safe-0.3.5.gem (100%)
Successfully installed thread_safe-0.3.5
Parsing documentation for thread_safe-0.3.5
Installing ri documentation for thread_safe-0.3.5
Done installing documentation for thread_safe after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install yajl-ruby -v '1.2
.1'
Fetching: yajl-ruby-1.2.1.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
Successfully installed yajl-ruby-1.2.1
Parsing documentation for yajl-ruby-1.2.1
Installing ri documentation for yajl-ruby-1.2.1
Done installing documentation for yajl-ruby after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install json -v '2.0.2'
Fetching: json-2.0.2.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
Successfully installed json-2.0.2
Parsing documentation for json-2.0.2
Installing ri documentation for json-2.0.2
Done installing documentation for json after 7 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install oj -v '2.17.5'
Fetching: oj-2.17.5.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
Successfully installed oj-2.17.5
Parsing documentation for oj-2.17.5
Installing ri documentation for oj-2.17.5
Done installing documentation for oj after 4 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install parallel -v '1.9.0'
Fetching: parallel-1.9.0.gem (100%)
Successfully installed parallel-1.9.0
Parsing documentation for parallel-1.9.0
Installing ri documentation for parallel-1.9.0
Done installing documentation for parallel after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install power_assert -v '
0.3.1'
Fetching: power_assert-0.3.1.gem (100%)
Successfully installed power_assert-0.3.1
Parsing documentation for power_assert-0.3.1
Installing ri documentation for power_assert-0.3.1
Done installing documentation for power_assert after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install rr -v '1.2.0'
Fetching: rr-1.2.0.gem (100%)
Successfully installed rr-1.2.0
Parsing documentation for rr-1.2.0
Installing ri documentation for rr-1.2.0
Done installing documentation for rr after 3 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install simplecov-html -v
 '0.10.0'
Fetching: simplecov-html-0.10.0.gem (100%)
Successfully installed simplecov-html-0.10.0
Parsing documentation for simplecov-html-0.10.0
Installing ri documentation for simplecov-html-0.10.0
Done installing documentation for simplecov-html after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install timecop -v '0.8.1'
Fetching: timecop-0.8.1.gem (100%)
Successfully installed timecop-0.8.1
Parsing documentation for timecop-0.8.1
Installing ri documentation for timecop-0.8.1
Done installing documentation for timecop after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install ffi-win32-extensi
ons -v '1.0.3'
Fetching: ffi-win32-extensions-1.0.3.gem (100%)
Successfully installed ffi-win32-extensions-1.0.3
Parsing documentation for ffi-win32-extensions-1.0.3
Installing ri documentation for ffi-win32-extensions-1.0.3
Done installing documentation for ffi-win32-extensions after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install win32-ipc -v '0.6
.6'
Fetching: win32-ipc-0.6.6.gem (100%)
Successfully installed win32-ipc-0.6.6
Parsing documentation for win32-ipc-0.6.6
Installing ri documentation for win32-ipc-0.6.6
Done installing documentation for win32-ipc after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install windows-api -v '0.4.4'
Fetching: windows-api-0.4.4.gem (100%)
Successfully installed windows-api-0.4.4
Parsing documentation for windows-api-0.4.4
Installing ri documentation for windows-api-0.4.4
Done installing documentation for windows-api after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install tzinfo -v '1.2.2'
Fetching: tzinfo-1.2.2.gem (100%)
Successfully installed tzinfo-1.2.2
Parsing documentation for tzinfo-1.2.2
Installing ri documentation for tzinfo-1.2.2
Done installing documentation for tzinfo after 5 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install parallel_tests -v
 '0.15.4'
Fetching: parallel_tests-0.15.4.gem (100%)
Successfully installed parallel_tests-0.15.4
Parsing documentation for parallel_tests-0.15.4
Installing ri documentation for parallel_tests-0.15.4
Done installing documentation for parallel_tests after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install test-unit -v '3.2
.1'
Fetching: test-unit-3.2.1.gem (100%)
Successfully installed test-unit-3.2.1
Parsing documentation for test-unit-3.2.1
Installing ri documentation for test-unit-3.2.1
Done installing documentation for test-unit after 5 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install simplecov -v '0.1
2.0'
Fetching: simplecov-0.12.0.gem (100%)
Successfully installed simplecov-0.12.0
Parsing documentation for simplecov-0.12.0
Installing ri documentation for simplecov-0.12.0
Done installing documentation for simplecov after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install win32-service -v
'0.8.9'
Fetching: win32-service-0.8.9.gem (100%)
Successfully installed win32-service-0.8.9
Parsing documentation for win32-service-0.8.9
Installing ri documentation for win32-service-0.8.9
Done installing documentation for win32-service after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install win32-event -v '0
.6.3'
Fetching: win32-event-0.6.3.gem (100%)
Successfully installed win32-event-0.6.3
Parsing documentation for win32-event-0.6.3
Installing ri documentation for win32-event-0.6.3
Done installing documentation for win32-event after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install windows-pr -v '1.
2.5'
Fetching: windows-pr-1.2.5.gem (100%)
Successfully installed windows-pr-1.2.5
Parsing documentation for windows-pr-1.2.5
Installing ri documentation for windows-pr-1.2.5
Done installing documentation for windows-pr after 4 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install tzinfo-data -v '1
.2016.8'
Fetching: tzinfo-data-1.2016.8.gem (100%)
Successfully installed tzinfo-data-1.2016.8
Parsing documentation for tzinfo-data-1.2016.8
Installing ri documentation for tzinfo-data-1.2016.8
Done installing documentation for tzinfo-data after 1 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install test-unit-rr -v '
1.0.5'
Fetching: test-unit-rr-1.0.5.gem (100%)
Successfully installed test-unit-rr-1.0.5
Parsing documentation for test-unit-rr-1.0.5
Installing ri documentation for test-unit-rr-1.0.5
Done installing documentation for test-unit-rr after 0 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install serverengine -v '
2.0.1'
Fetching: serverengine-2.0.1-x64-mingw32.gem (100%)
Successfully installed serverengine-2.0.1-x64-mingw32
Parsing documentation for serverengine-2.0.1-x64-mingw32
Installing ri documentation for serverengine-2.0.1-x64-mingw32
Done installing documentation for serverengine after 2 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/……..
Fetching version metadata from https://rubygems.org/.
Resolving dependencies…
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Using win32-service 0.8.9
Using win32-event 0.6.3
Using windows-pr 1.2.5
Using tzinfo-data 1.2016.8
Using test-unit-rr 1.0.5
Using serverengine 2.0.1
Using fluentd 0.14.8 from source at `.`
Bundle complete! 10 Gemfile dependencies, 34 gems now installed.
Use `bundle show [gemname]` to see where a bundled gem is installed.

ぐっは、長かったなぁ;もう十数年も前の新入社員時代を思い出す。cpanm がなかった頃、CPAM モジュールを tar ボールからインストールすることでとにかく体で覚えるという試練。。つか、なんかもっと良いやり方ないものか。

クローンした fluentd を bundler で gem パッケージにする

やっとその時がきました!つくっておいた fluentd の gem は Ruby 2.2 系をインストールしさえすれば、他の端末でも使いまわせることでしょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle exec rake build
fluentd 0.14.8 built to pkg/fluentd-0.14.8.gem.

できたw

fluentd のインストール

ドキュメント不要な場合は –no-ri –no-rdoc オプションを付与すると良いです。この例ではドキュメントもインストールされます。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install pkg\fluentd-0.14.
8.gem
Successfully installed fluentd-0.14.8
Parsing documentation for fluentd-0.14.8
Installing ri documentation for fluentd-0.14.8
Done installing documentation for fluentd after 16 seconds
WARNING:  Unable to pull data from 'https://rubygems.org/': SSL_connect returned
=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (htt
ps://api.rubygems.org/specs.4.8.gz)
1 gem installed
fluentd-on-windows2008r2_3

Windows 上にインストールされた fluentd

トラブルシューティング

DevKit の初期化後、ruby dk.rb install をしようとしたら Invalid configuration or no rubies listed…

config.xml を編集しましょう。

c:\rubydevkit>ruby dk.rb install
Invalid configuration or no Rubies listed. Please fix 'config.yml'
and rerun 'ruby dk.rb install'

Unable to download data from https://rubygems.org/

サーバ証明書の検証に失敗したため。以下のコマンドで HTTP で rubygems.org にアクセスすることで代替可。
gem source -a http://rubygems.org/

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>gem install bundler
ERROR:  Could not find a valid gem 'bundler' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - SSL_connect retur
ned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (
https://api.rubygems.org/specs.4.8.gz)

fluentd を bundle しようとしたら An error occurred while installing rake (11.3.0), and Bundler cannot continue.

gem install rake -v ‘11.3.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/rake-11.3.0.gem)
An error occurred while installing rake (11.3.0), and Bundler cannot continue.
Make sure that `gem install rake -v '11.3.0'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing cool.io (1.4.5), and Bundler cannot continue.

gem install cool.io -v ‘1.4.5’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/cool.io-1.4.5-x64-mingw32.gem)
An error occurred while installing cool.io (1.4.5), and Bundler cannot continue.

Make sure that `gem install cool.io -v '1.4.5'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing docile (1.1.5), and Bundler cannot continue.

gem install docile -v ‘1.1.5’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/docile-1.1.5.gem)
An error occurred while installing docile (1.1.5), and Bundler cannot continue.
Make sure that `gem install docile -v '1.1.5'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing ffi (1.9.14), and Bundler cannot continue.

gem install ffi -v ‘1.9.14’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/ffi-1.9.14-x64-mingw32.gem)
An error occurred while installing ffi (1.9.14), and Bundler cannot continue.
Make sure that `gem install ffi -v '1.9.14'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing flexmock (2.3.1), and Bundler cannot continue.

gem install flexmock -v ‘2.3.1’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/flexmock-2.3.1.gem)
An error occurred while installing flexmock (2.3.1), and Bundler cannot continue.
Make sure that `gem install flexmock -v '2.3.1'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing http_parser.rb (0.6.0), and Bundler cannot continue.

gem install http_parser.rb -v ‘0.6.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/http_parser.rb-0.6.0.gem)
An error occurred while installing http_parser.rb (0.6.0), and Bundler cannot continue.
Make sure that `gem install http_parser.rb -v '0.6.0'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing msgpack (1.0.2), and Bundler cannot continue.

gem install msgpack -v ‘1.0.2’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/msgpack-1.0.2-x64-mingw32.gem)
An error occurred while installing msgpack (1.0.2), and Bundler cannot continue.

Make sure that `gem install msgpack -v '1.0.2'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing sigdump (0.2.4), and Bundler cannot continue.

gem install sigdump -v ‘0.2.4’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/sigdump-0.2.4.gem)
An error occurred while installing sigdump (0.2.4), and Bundler cannot continue.

Make sure that `gem install sigdump -v '0.2.4'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing win32-api (1.6.0), and Bundler cannot continue.

gem install win32-api -v ‘1.6.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/win32-api-1.6.0-universal-mingw32.gem)
An error occurred while installing win32-api (1.6.0), and Bundler cannot continue.
Make sure that `gem install win32-api -v '1.6.0'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing strptime (0.1.8), and Bundler cannot continue.

gem install strptime -v ‘0.1.8’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/strptime-0.1.8-x64-mingw32.gem)
An error occurred while installing strptime (0.1.8), and Bundler cannot continue.
Make sure that `gem install strptime -v '0.1.8'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing thread_safe (0.3.5), and Bundler cannot continue.

gem install thread_safe -v ‘0.3.5’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/thread_safe-0.3.5.gem)
An error occurred while installing thread_safe (0.3.5), and Bundler cannot continue.
Make sure that `gem install thread_safe -v '0.3.5'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing yajl-ruby (1.2.1), and Bundler cannot continue.

gem install yajl-ruby -v ‘1.2.1’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/yajl-ruby-1.2.1.gem)
An error occurred while installing yajl-ruby (1.2.1), and Bundler cannot continue.
Make sure that `gem install yajl-ruby -v '1.2.1'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing json (2.0.2), and Bundler cannot continue.

gem install json -v ‘2.0.2’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/json-2.0.2.gem)
An error occurred while installing json (2.0.2), and Bundler cannot continue.
Make sure that `gem install json -v '2.0.2'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing oj (2.17.5), and Bundler cannot continue.

gem install oj -v ‘2.17.5’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/oj-2.17.5.gem)
An error occurred while installing oj (2.17.5), and Bundler cannot continue.
Make sure that `gem install oj -v '2.17.5'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing parallel (1.9.0), and Bundler cannot continue.

gem install parallel -v ‘1.9.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/parallel-1.9.0.gem)
An error occurred while installing parallel (1.9.0), and Bundler cannot continue.
Make sure that `gem install parallel -v '1.9.0'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing power_assert (0.3.1), and Bundler cannot continue.

gem install power_assert -v ‘0.3.1’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/power_assert-0.3.1.gem)
An error occurred while installing power_assert (0.3.1), and Bundler cannot continue.
Make sure that `gem install power_assert -v '0.3.1'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing rr (1.2.0), and Bundler cannot continue.

gem install rr -v ‘1.2.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/rr-1.2.0.gem)
An error occurred while installing rr (1.2.0), and Bundler cannot continue.
Make sure that `gem install rr -v '1.2.0'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing simplecov-html (0.10.0), and Bundler cannot continue.

gem install simplecov-html -v ‘0.10.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/simplecov-html-0.10.0.gem)
An error occurred while installing simplecov-html (0.10.0), and Bundler cannot continue.
Make sure that `gem install simplecov-html -v '0.10.0'` succeeds before
bundling.

fluentd を bundle しようとしたら An error occurred while installing timecop (0.8.1), and Bundler cannot continue.

gem install timecop -v ‘0.8.1’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/timecop-0.8.1.gem)
An error occurred while installing timecop (0.8.1), and Bundler cannot continue.

Make sure that `gem install timecop -v '0.8.1'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing ffi-win32-extensions (1.0.3), and Bundler cannot continue.

gem install ffi-win32-extensions -v ‘1.0.3’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/ffi-win32-extensions-1.0.3.gem)
An error occurred while installing ffi-win32-extensions (1.0.3), and Bundler cannot continue.
Make sure that `gem install ffi-win32-extensions -v '1.0.3'` succeeds before
bundling.

fluentd を bundle しようとしたら An error occurred while installing win32-ipc (0.6.6), and Bundler cannot continue.

gem install win32-ipc -v ‘0.6.6’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/win32-ipc-0.6.6.gem)
An error occurred while installing win32-ipc (0.6.6), and Bundler cannot continue.
Make sure that `gem install win32-ipc -v '0.6.6'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing windows-api (0.4.4), and Bundler cannot continue.

gem install windows-api -v ‘0.4.4’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/windows-api-0.4.4.gem)
An error occurred while installing windows-api (0.4.4), and Bundler cannot continue.
Make sure that `gem install windows-api -v '0.4.4'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing tzinfo (1.2.2), and Bundler cannot continue.

gem install tzinfo -v ‘1.2.2’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/tzinfo-1.2.2.gem)
An error occurred while installing tzinfo (1.2.2), and Bundler cannot continue.
Make sure that `gem install tzinfo -v '1.2.2'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing parallel_tests (0.15.4), and Bundler cannot continue.

gem install parallel_tests -v ‘0.15.4’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/parallel_tests-0.15.4.gem)
An error occurred while installing parallel_tests (0.15.4), and Bundler cannot continue.
Make sure that `gem install parallel_tests -v '0.15.4'` succeeds before
bundling.

fluentd を bundle しようとしたら An error occurred while installing test-unit (3.2.1), and Bundler cannot continue.

gem install test-unit -v ‘3.2.1’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/test-unit-3.2.1.gem)
An error occurred while installing test-unit (3.2.1), and Bundler cannot continue.
Make sure that `gem install test-unit -v '3.2.1'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing simplecov (0.12.0), and Bundler cannot continue.

gem install simplecov -v ‘0.12.0’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/simplecov-0.12.0.gem)
An error occurred while installing simplecov (0.12.0), and Bundler cannot continue.
Make sure that `gem install simplecov -v '0.12.0'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing win32-service (0.8.9), and Bundler cannot continue.

gem install win32-service -v ‘0.8.9’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/win32-service-0.8.9.gem)
An error occurred while installing win32-service (0.8.9), and Bundler cannot continue.
Make sure that `gem install win32-service -v '0.8.9'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing win32-event (0.6.3), and Bundler cannot continue.

gem install win32-event -v ‘0.6.3’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Using win32-service 0.8.9
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/win32-event-0.6.3.gem)
An error occurred while installing win32-event (0.6.3), and Bundler cannot continue.
Make sure that `gem install win32-event -v '0.6.3'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing windows-pr (1.2.5), and Bundler cannot continue.

gem install windows-pr -v ‘1.2.5’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Using win32-service 0.8.9
Using win32-event 0.6.3
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/windows-pr-1.2.5.gem)
An error occurred while installing windows-pr (1.2.5), and Bundler cannot continue.
Make sure that `gem install windows-pr -v '1.2.5'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing tzinfo-data (1.2016.8), and Bundler cannot continue.

gem install tzinfo-data -v ‘1.2016.8’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Using win32-service 0.8.9
Using win32-event 0.6.3
Using windows-pr 1.2.5
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/tzinfo-data-1.2016.8.gem)
An error occurred while installing tzinfo-data (1.2016.8), and Bundler cannot
continue.
Make sure that `gem install tzinfo-data -v '1.2016.8'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing test-unit-rr (1.0.5), and Bundler cannot continue.

gem install test-unit-rr -v ‘1.0.5’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Using win32-service 0.8.9
Using win32-event 0.6.3
Using windows-pr 1.2.5
Using tzinfo-data 1.2016.8
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/test-unit-rr-1.0.5.gem)
An error occurred while installing test-unit-rr (1.0.5), and Bundler cannot continue.
Make sure that `gem install test-unit-rr -v '1.0.5'` succeeds before bundling.

fluentd を bundle しようとしたら An error occurred while installing serverengine (2.0.1), and Bundler cannot continue.

gem install serverengine -v ‘2.0.1’ しましょう。

C:\Users\ADMINI~1.NEO\AppData\Local\Temp\1\fluentd>bundle
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 11.3.0
Using cool.io 1.4.5
Using docile 1.1.5
Using ffi 1.9.14
Using flexmock 2.3.1
Using http_parser.rb 0.6.0
Using msgpack 1.0.2
Using sigdump 0.2.4
Using win32-api 1.6.0
Using strptime 0.1.8
Using thread_safe 0.3.5
Using yajl-ruby 1.2.1
Using json 2.0.2
Using oj 2.17.5
Using parallel 1.9.0
Using power_assert 0.3.1
Using rr 1.2.0
Using simplecov-html 0.10.0
Using timecop 0.8.1
Using bundler 1.13.6
Using ffi-win32-extensions 1.0.3
Using win32-ipc 0.6.6
Using windows-api 0.4.4
Using tzinfo 1.2.2
Using parallel_tests 0.15.4
Using test-unit 3.2.1
Using simplecov 0.12.0
Using win32-service 0.8.9
Using win32-event 0.6.3
Using windows-pr 1.2.5
Using tzinfo-data 1.2016.8
Using test-unit-rr 1.0.5
Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read
server certificate B: certificate verify failed
(https://rubygems.org/gems/serverengine-2.0.1-x64-mingw32.gem)
An error occurred while installing serverengine (2.0.1), and Bundler cannot continue.
Make sure that `gem install serverengine -v '2.0.1'` succeeds before bundling.
スポンサーリンク

シェアする

フォローする

スポンサーリンク